源码安装错误

参考使用源码安装的教程:
https://docs.nebula-graph.com.cn/manual-CN/3.build-develop-and-administration/1.build/1.build-source-code/#third_party
在make install 错误

上面告诉你没有权限了,默认安装到/usr/local/nebula/,需要root权限

1 个赞

默认安装到 /usr/local/

要么你用 sudo make install,要么指定 CMAKE_INSTALL_PREFIX 编译源代码 - Nebula Graph 手册

2 个赞

image

多谢,现在make install 成功了,但在下一步复制配置文件出现新的问题。


然后再etc、目录下确实没有该文件。

你用的是哪个版本在编译?

@steam 这个提问似乎信息不全?

@RandomJoe 这个手册没有版本?

嗯,是我审核的时候没仔细,count +1,顺便 @borges 补充下在编译的 Nebula 版本号吧

有指定cmake 参数 -DENABLE_BUILD_STORAGE=on 吗?看着像没有build storage

docs.nebula-graph.com.cn/manual-CN/下的是老1.0手册,当时没有标版本的,已经弃用了,为了防止断链才保持了路径不变。后来的1.x和2.x文档都有版本号,且路径也不一样了

这个处理一下吧,容易给用户造成误解

老版文档已经弃用了,不再维护,链接都没又放出了。目前的文档中心没有这个问题

最好加个弃用说明,以及新文档的链接

照样是有的!

感谢各位。
确实是版本的问题,我git了最新的版本,但是用了之前的手册。所以出现了各种错误。
建议在手册提醒用户使用的git版本。

1 个赞

浙ICP备20010487号