初次使用发现无法连接2.0 GA studio


我用的是rpm包部署的。集群模式,三个节点
问题1:配置数据库下面第一个输入框写的是 Host,但是提示确实0端口有问题。请问这里时要配置端口+ip吗
问题2。这个host该配置哪个?每一个配置文件(nebula-graphd.conf、nebula-metad.conf、nebula-storaged.conf)都有–ws_ip=0.0.0.0 ,他们有什么区别,如果我想在studio中连上nebula 我该用哪一个在哪里配置呢
问题3.当我配置成如下所示的时候又报如下错误

您好
问题1,没错是配置 ip:port
问题2,这里要配置的是 graphd的ip:port 哈,默认是9669的

参考文档
https://docs.nebula-graph.com.cn/2.0.1/nebula-studio/deploy-connect/st-ug-connect/
我引用文档的段落

Host:填写 Nebula Graph 的 Graph 服务本机 IP 地址及端口。格式为 ip:port。如果端口未修改,则使用默认端口 9669。

  1. 建议修改提示,或者就用中文写IP端口号:看到下面的提示真的很难让人想到是端口的问题

    2.最后发现和–ws_ip=0.0.0.0 没有关系,尽管这个写的注释是http服务。

    3.我用的是2.0.0 url改成2.0.0发现没有文档。不过在您专业的解答下,我成功的登录进去了。也对这两个配置属性有了更加深入的理解

多谢您的细心和反馈哈。

3.我用的是2.0.0 url改成2.0.0发现没有文档。

确实,各个版本之间的文档的目录结构有变化,这使得修改url里边的版本不能找到旧版本的等价的章节。
在2.0的文档里对应的章节URL是 连接数据库 - Nebula Graph Database 内核手册

这里的2.0端口号信息是不对的,麻烦还是参考2.0.1的(小版本内这些信息是无差别的),我会去修复一下。

  1. 建议修改提示,或者就用中文写IP端口号:看到下面的提示真的很难让人想到是端口的问题
  2. 最后发现和–ws_ip=0.0.0.0 没有关系,尽管这个写的注释是http服务。
  1. 这里确实有一些迷惑人,如果去和 2.结合看的时候,2.原意是web server的 host IP,我们想一下怎么改进一下哈

hmmm… 看了一下这个文档还有问题,这里面说的端口是端口是3699。。
ps:我用的是 nebula-graph-studio-2.2.0-1.x86_64.rpm

多谢哈,是的,我也注意到了,您有没有兴趣贡献 PR FIX这里呢? :blush:

1 个赞

我去试试

好滴好滴,如果您 PR 过程中 有问题随时私信我,或者微信联系我,我的微信id是

echo c2l2dmVpCg== | base64 -d
1 个赞
  1. 点击右上角铅笔,直接修改
  2. 用2.0.1吧。 2.0.0代码和文档都不维护了。
1 个赞

问题被 PR: Update st-ug-connect.md (#410) · vesoft-inc/nebula-docs-cn@769db1f · GitHub 修复了,您是作者么?:+1:t2:

是我,我点击右上角铅笔改的 :grin:

1 个赞

太赞了,欢迎您成为 Nebula 社区 Active Contributor(三个以上贡献)!感谢您的付出!期待您的继续参与!

哈哈哈,原来参与开源没有那么难

3 个赞

是呀,恭喜开启新的大门 :blush:

浙ICP备20010487号