studio 3.0.0源码运行错误

运行gitub上开源的studio源码 第一步运行importer是报错如下 :
1630401468(1)

请问如何解决?

。。大兄弟,你 rm -rf 执行了吗?执行了就跑路吧。Studio 是依赖 nebula-importer 和 nebula-http-gateway 服务的

1 个赞

执行rm -rf是什么意思?

。。哥,你这个命令都不知道吗,你去百度下。如果你想不开了,就可以执行下这个命令

1 个赞

你要起来 Studio 服务,去重新装一个 nebula-importer 吧 https://github.com/vesoft-inc/nebula-importer ,然后把 importer 的服务起来之后再启动 Studio

我没有执行rm-rf 我是按着gitub上的文档 启动importer的 报错就是像上面那个一样

补充一下 上图报错是在 make-build之后提示的

为什么会make-build命令 这是什么命令?

可以参考这个


https://github.com/vesoft-inc/nebula-studio

就是执行 make build之后报错

报错信息贴下

rm -rf importer是build中的一步做cleanup,会不会是你的用户没有权限?你在nebula-importer目录下手动执行下这个试试?


这是importer目录下makefile的文件内容

这是golang环境没有装呢,参考这里 https://github.com/vesoft-inc/nebula-importer/blob/master/docs/golang-install-en.md

golang安装的过程中报错这个 怎么解决呢? go version已经有提示了

go要求1.13以后,先升级下

importer安装好了 现在运行源码的时候最后一步又出现了新错误

node 版本多少 重新安装一下依赖试试

我这个环境是可以跑官方文档上的studio的 但是运行不了源码 这是什么原因?我觉得不是我环境的问题

浙ICP备20010487号