console 连接线上的图数据库

Release Nebula Console v2.6.0 · vesoft-inc/nebula-console · GitHub预先格式化的文本
从这个连接下载的二进制文件
连接的过程中提示无法执行二进制文件

Windows 的系统?

macOS

mac m1


是我下载错文件了吗

darwin-arm64

1 个赞

https://zh.wikipedia.org/wiki/Darwin_(操作系统)

1 个赞

不提示无法执行了,提示

这是什么原因呢?

端口号错了吧,你用的2.6,Graph默认9669啊

1 个赞

要连接线上的图数据库,所以端口号不一样,找到问题所在了 因为版本太高了 不匹配所以一直连不上

1 个赞

如果这条回复解决了了你的问题,你可以勾选为解决方案,方便后续遇到相似问题的小伙伴快速找到答案呀~

现在高版本客户端连不上低版本的graph,因为2.5还是2.6的graph在连接前加了个verify的验证函数。低版本的客户端连的上高版本的graph,但是执行命令就卡死,我猜可能是改了rpc的参数。 :rofl:客户端不兼容我觉得挺不好的,好多客户端都给业务用了很久了,更新一次就改一次过于麻烦 :sweat_smile:

确实,会有这个问题,版本的更迭,应该是更方便才好

@sworduo 嗯嗯,我提了一个客户端向上兼容的 issue 给研发同学 https://github.com/vesoft-inc/nebula/issues/3803 你们可以关注下这个 issue 的进展情况哈~

1 个赞

具体是什么版本的数据库,+ 2.6的console?

我们在gateway的仓库里搞了一个兼容多版本nebula的client库,目前支持2.5、2.6、3.0三个版本,感兴趣可以了解一下 nebula-http-gateway/ccore at master · vesoft-inc/nebula-http-gateway · GitHub

1 个赞

嗯嗯 好的

:+1:t2: 求 port 这个能力到 console 哈

此话题已在最后回复的 30 天后被自动关闭。不再允许新回复。