spark使用nebula-exchange-2.6.0-jar读取自定义配置文件,连接hive导数据到Nebula Graph报方法类找不到

hive版本:2.1.1 ,scala版本:2.11.12 ,spark版本:2.4.0,hadoop版本:3.0.0,graph的客户端和服务端版本都是2.6.0

把你的配置文件贴一下,:thinking: storage 和 meta 的配置贴一下

Hive 的metaStore版本冲突,参考 Hive数据导入时提示schema 版本不一致的解决方法exchange2.0 hive导数报错NoSuchMethodError

2 个赞

是我自己写的配置文件还是hive的或者是nebula graph的?我自己写的文件配置和官网的实例基本上一样,除了ip那些,数据也是上面的数据样例。hive的版本是2.1.1的,它是cdh版本的,meta storage也是2.1.1的,nebula的server和client都是2.6.0的

可不可以替换掉nebula exchange里面的hive-metastore的版本

你可以尝试下,修改源码pom文件里引用的hive的版本号

好的,谢谢

:thinking: 如果你尝试之后,能跑起来服务了,你可以勾选 nicole 的回复为解决方案哈

浙ICP备20010487号