Star

请问2.0版本发布后数据格式兼容2.0-beta或1.0版本吗?

  • nebula 版本:2.0-beta
  • 部署方式:分布式:
  • 出问题的 Space 的创建方式:执行 go from '1' over follow;
  • 问题的具体描述
    采用2.0-beta版本进行测试,go语句
(root@nebula) [push_test]>  go from "100" over follow1
+--------------+
| follow1._dst |
+--------------+
| "102"        |
+--------------+
| "13654360"   |
+--------------+

升级到master版本进行测试,go语句的返回就为空:

(root@nebula) [push_test]>  go from "100" over follow1

master分支刚刚对数据格式进行了改动,需要重新导入数据。
1.0升级到2.0会提供升级工具。

2赞

我在2.0-beta上写入的数据,master分支也不兼容吗?

是的,因为刚刚改了底层数据接口

您好,请问 2.0-beta升级到2.0正式版后面会有工具吗?

目前还没有此升级工具的计划

请问master版本还会修改数据格式吗?如果不会修改的话,我把数据导出来重新导入一下。

我们也在计划做一个 2.x 到 2.0 GA的升级工具,这个升级工具短期内还不可用,可以先重新导入数据来解决当前问题。

已经这么做了,master版本 到2.0 发布之间数据格式不会再变了吧,不然可能又要重新导入数据了。

不建议最近这一两周导入 最近这块在改动 对于2.0会提供ga之前升级到ga的工具.

如果一定要做的话 建议使用storage这个commit之前的代码c830032 这个之后的会引入若干改动 最好不要有任何中间状态

浙ICP备20010487号