nebula2-python 对 python2 的支持

环境信息

  • nebula 版本:2.0.0-rc1
  • nebula-python 版本:v2.0.0rc1

问题的具体描述:nebula2-python setup 文件中写着支持 python 2.7 ,但代码里包含 python3 的语法,比如:

nebula-python/nebula2/data/DataObject.py 第 397 行

    def __eq__(self, o: object) -> bool:
        if not isinstance(o, self.__class__):

在 python 2.7 中使用会报错:

新版本不去对python2进行兼容。

1赞

浙ICP备20010487号